The first steps are:

Assign me to some groups so I can shut down the computer and use as much memory as I need

usermod -G operator username
usermod -G staff username
usermod -G wheel username

OpenBSD comes with doas by default, which has a simpler configuration and is more secure than sudo. My usual go-to configuration for it in /etc/doas.conf is simple:

permit persist :wheel

Enable and start apmd:

rcctl enable apmd
rcctl set apmd flags -L
rcctl start apmd

OpenBSD limits the memory usage for each user. It’s a good idea to change the staff group limits like so in /etc/login.conf:

#
# Staff have fewer restrictions and can login even when nologins are set.
#
staff:\
    :datasize-cur=32768M:\
    :datasize-max=infinity:\
    :maxproc-max=512:\
    :maxproc-cur=256:\
    :ignorenologin:\
    :requirehome@:\
    :tc=default:

Then, change the login class for the user. After the next login, it will be able to use the resources defined in login.conf:

usermod -L staff username
userinfo username

Note this is completely inappropriate on a multi-user system because 2 users can force the system into the swap. This limit is for a system with 64GB of RAM.

Now, install some programs so you can automate those survival plants and keep track and plan crops on fields:

doas pkg_add libreoffice
doas pkg_add vlc
doas pkg_add neovim
doas pkg_add firefox

Note that Firefox is not de-badged by default, you will have to disable trackers and pocket to make it suitable for the paranoid user.

The biggest advantage of OpenBSD is the man pages, which is great documentation for every program that’s in the system. I often find myself using it more often than searching for usage and issues online. For example, to access the manual for the doas command:

man doas

What can you do with OpenBSD?

Well, anything that does not require closed source blobs. I can program my favourite arduino boards, great to automate the chicken tractor and the main gate for the stronghold.

With Libreoffice, I can view and edit documents and sheets, I can even read and edit MS Office documents.

Webcam works, including its microphone. I think OpenBSD’s sound system is far superior to what’s available in Linux as Pulseaudio. It is also free of any Systemd (Soystemd)

Virtualisation with qemu. Sorry guys, vmm is just not suitable for what I need it for. I can spin up Linux or Windows guests with qemu when I need them.

What does not work?

Nvidia graphics cards because it lacks the open source-driver.

Bluetooth was removed because the developers did not find a way for a clean implementation.

Zoom, Skype and Slack because these are closed source programs.

KeepassXC can’t be used in the browser for some unknown reason. “Key authentication failed”. I will give it some more research later, but other users also complained about this.

No woke Code Of Conducts

Thank God the OpenBSD developers did not adopt these lunatic COC’s but kept their mailing list rules simple. It starts with “Plain text, 72 characters per line” and ends with “Respect differences in opinion and philosophy”. Nothing more is needed to say about sexual orientations and pronouns.

Updated:

Comments